Автор Тема: Учет затрат по процессам: Ведение схем: Синтаксическая ошибка в формуле схемы  (Прочитано 9675 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Uukrul

  • SAP ECC 6.0 Ehp(*)
  • Administrator
  • Epic Member
  • *****
  • Сообщений: 3 762
  • Репутация: +47/-0
  • Пол: Мужской
  • YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
    • Sapforum.BIZ
В качестве дружеской поддержки, при настройке CO, возник вопрос, если посмотреть в отладке, похоже идет не правильный парсинг формул, дальше как-то разбираться тяжело, к тому же вроде как формулы вводятся через графический дизайнер формул. По шагам типа описание ниже.

В IDES, при ведении схемы для планирования затрат на продукт создается схема для процесса, в схеме используется формула. Формула создается используя дизайнер ввода формул, после создания формулы система диагностирует синтаксическую ошибку. Внутри генерируется сообщение KW 314, по SAP-notes есть только одна заметка по этому поводу для системы 4.6С для японских городовых.

По шагам:
1.1 Настройка схемы в SPRO. рисунок SPRO.png
1.2 Выбираем изменение схемы SPRO-1.png

2.1 Контроллинговая единица 1000 (стандартно для IDES), рисунок SPRO-2.png
2.2 Далее создали схему PROD23 в среде 001, рисунок SPRO-3.png

3.1 Далее для бизнес-процесса в колонке активирование планирования двойной клик и переходим к ведению формулы, рисунок CPT2.png
3.2 Используем функцию которая читает материал из процесса, материал классифицирован, если признак T-COLOR не равент 3, то включается этот процесс. Функция в дизайнере заполняется значениями, для этого она выбрана в дереве существующих функций, рисунок CPT2-1.png
3.3 После ввода значений в дизайнере функции, в редакторе формул система формирует автоматически текст формулы, рисунок CPT2-2.png и сообщается об ошибке синтаксиса, рисунок CPT2-3.png.

Вопрос, что делаем не так?

Оффлайн Uukrul

  • SAP ECC 6.0 Ehp(*)
  • Administrator
  • Epic Member
  • *****
  • Сообщений: 3 762
  • Репутация: +47/-0
  • Пол: Мужской
  • YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
    • Sapforum.BIZ
В общем, в 4.6 оно таки работает как надо.. похоже что какая-то проблема или в 6.0 вообще или именно в этой 6.0

ilinvv

  • Гость
привет
беда в имени параметра "Имя класса"
точнее в пробеле между словами

нужно править имя параметра в ctu6 (например на "Имя_класса")

ilinvv

  • Гость
You are not allowed to view links. Register or Login
привет
беда в имени параметра "Имя класса"
точнее в пробеле между словами

нужно править имя параметра в ctu6 (например на "Имя_класса")
тьху, "ВИД_КЛАССА" конечно же)))

Оффлайн Uukrul

  • SAP ECC 6.0 Ehp(*)
  • Administrator
  • Epic Member
  • *****
  • Сообщений: 3 762
  • Репутация: +47/-0
  • Пол: Мужской
  • YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
    • Sapforum.BIZ
О, спасибо... сейчас проверим-с...

Таня

  • Гость
You are not allowed to view links. Register or Login
тьху, "ВИД_КЛАССА" конечно же)))

Спасибо, все получилось. А как можно было понять, что проблема в этом?

Оффлайн ilinvv

  • Newbie
  • *
  • Сообщений: 6
  • Репутация: +0/-0
  • YearsYearsYearsYearsYearsYearsYearsYearsYearsYearsYears
интуитивно методом научного тыка
или надавить на глаза консультантам  ;D